[MITgcm-support] Re: compiling MITgcm

Ed Hill ed at eh3.com
Tue Feb 15 22:11:20 EST 2005

Hi Kelvin,

I've subscribed you to this list so any further emails from your address
will be accepted automatically.  And I've included your original email
below for reference.

In regards to the Sun build/test problems, it seems that your gcc-g77
install isn't happy.  Its trying to use a dynamically linked g2c library
and this is probably due to an odd or botched gcc-g77 install.  Google
gives a number of links that report similar errors such as:


So are you *sure* that gcc and g77 are properly installed on your Suns?
For instance, are you able to produce working Fortran programs using
simple "hello_world.f"-type programs?

And for the Altix system, could you please send us a more detailed bug
report?  A cut-and-paste of the exact commands you used and the exact
error message(s) you received would be very helpful.  A significant
fraction of the current MITgcm users are routinely running their
simulations on Altix systems so they are known to work well!


=== Original Email ===
Kelvin Richards <rkelvin at hawaii.edu>
mitgcm-support at mitgcm.org
compiling MITgcm
Tue, 15 Feb 2005 16:28:12 -1000
(21:28 EST)
        I am trying to install the MITgcm on our local machines and am
        having a 
        number of problems. I hope you dont mind questions from novices!
        Solaris machine:
        Following the installation guidelines on your web page I tried 
        'verifying'  exp5. The automatic machine detection picks up the 
        build_option  sunos_sun4u_g77, produces an executable, but fails
        run, complaining that it cannot find libg2c.so.0. This appears
        to be a 
        library of gcc_g77 which is not installed on our machines.
        sunos_sun4u_f77 gives the same error). Is it possible to run
        this particular library? If so how? If not, then I will see
        getting it installed. However it would be useful if there a list
        of the 
        necessary libraries to run the model, and where the code is
        them to be (I cannot find a reference to libraries from a quick
        of the Makefile).
        For exp0 the compilation failed completely at the linking stage
        sure why at this stage)
        I tried compiling on an Altix machine (using both the automatic 
        detection and linux_ia64_efc+mpi_altix). Both failed. I will
        seek local 
        advice, but is there someone who I can ask for help if
        Kelvin Richards
        University of Hawaii, POST Bldg. 406E
        1680 East West Road
        Honolulu, Hawaii 96822
        Telephone: (808) 956-5399
        Fax:       (808) 956-9425
        email:     rkelvin at hawaii.edu
        === Original Email ===

Edward H. Hill III, PhD
office:  MIT Dept. of EAPS;  Rm 54-1424;  77 Massachusetts Ave.
             Cambridge, MA 02139-4307
emails:  eh3 at mit.edu                ed at eh3.com
URLs:    http://web.mit.edu/eh3/    http://eh3.com/
phone:   617-253-0098
fax:     617-253-4464

More information about the MITgcm-support mailing list