[MITgcm-support] OBCS CPP flag

Julie Deshayes jdeshayes at whoi.edu
Fri Jun 8 19:28:12 EDT 2007

I am trying to add OBCS to my configuration with MITgcm but I can't ! 
here is a list of different things that I tried and failed :

- I added obcs to packages.conf and/or did genmake2 enable obcs ... 
(OBCS_OPTIONS.h being included in my directory code/).
the compilation would go through with no error message, but when I run 
the executable,  I have the following error message : "Run-time control 
flag useOBCS was used when CPP flag ALLOW_OBCS was unset".

- when trying to add #define ALLOW_OBCS in CPP_OPTIONS.h, in addition to 
the modifications above (still with OBCS_OPTIONS.h in my directory 
code/), then the compilation would NOT go through and I get the error 
message : "<stdin>:7: OBCS_OPTIONS.h: No such file or directory".

do you have any clue about what I am doing wrong ?

let me know if you want me to send any of my configuration files.
sorry if this problem have already been addressed, I have been through 
the previous emails and could not find anything helpful ...

have a good week end too !

More information about the MITgcm-support mailing list