[MITgcm-support] Error with Arctic configuration and runoff file

gmail mozzatoale at gmail.com
Wed Feb 17 12:45:51 EST 2016

Dear MITgcm users,

I am currently running an Arctic configuration of the MITgcm in 3 different resolutions: 36km, 18km and 9km.
I started using the ERA  dataset for forcing and all three worked fine. 

I have now switched to the CORE2 dataset forcing and setup my data.exf following the one I found here:
http://mitgcm.org/viewvc/MITgcm/MITgcm_contrib/gael/verification/global_oce_llc90/input.core2/ <http://mitgcm.org/viewvc/MITgcm/MITgcm_contrib/gael/verification/global_oce_llc90/input.core2/>

This new setup works fine on the 36km configuration producing satisfying results.
The problems arise with the 9km and 18km configuration. More specifically the problem seems to be related to the runoff.
Both configurations throw the following error:

forrtl: severe (36): attempt to access non-existent record, unit 9, file /hpcdata/scratch/am8e13/CORE_data/runoff-corev2_360x180x12.bin

Here is a copy of my data.exf:
https://github.com/AlessandroMozzato/notebooks/blob/master/data.exf <https://github.com/AlessandroMozzato/notebooks/blob/master/data.exf> 

I have checked the file in MATLAB and it seems fine and with the right dimensions.
I have also tried to substitute the runoff from the CORE dataset with the runoff from the ERA dataset and the same error is produced. 
I have tried both of these setups for the data.exf:

 runoffstartdate1  = 19470115,
 runoffstartdate2  = 120000,
 runoffperiod      = 2628000.0,
 runoffperiod      = 2592000.0,


 runoffperiod      = -12,

Finally I have added the following lines to the data.exf

 runoff_lon0       = 0.50D0,
 runoff_lon_inc    = 1.0D0,
 runoff_lat0       = -89.5D0,
 runoff_lat_inc    = 1.,
 runoff_nlon       = 360,
 runoff_nlat       = 180,

It is also worth noticing that removing the runoff file from data.exf solves the problem and the model runs fine. 
I suspect this could be an easy fix but I couldn’t figure it how.

Every suggestion would be greatly appreciated!

All the best,

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mitgcm.org/pipermail/mitgcm-support/attachments/20160217/e9d47f84/attachment.htm>

More information about the MITgcm-support mailing list