[MITgcm-support] mitgcm 52k

Michael Beck beck at ocean.fsu.edu
Fri Apr 7 08:43:44 EDT 2006

Hi Ed

I tried as you suggested and the following error came up when I ran the 
  make command

ocnpc84:~/myDir/MITgcm/verification/exp0/build beck$ make
/opt/ibmcmp/xlf/8.1/bin/f77  -O3 -c debug_call.f
"debug_call.f", line 4.0: 1515-005 (S) Continuation line is not  
permitted at beginning of program or after INCLUDE, EJECT, @PROCESS  
statements or comment directive.  Line is ignored.
"debug_call.f", line 17.10: 1515-019 (S) Syntax is incorrect.
"debug_call.f", line 21.6: 1514-050 (S) Specification statement is out  
of order.  Statement is ignored.
"debug_call.f", line 22.6: 1514-050 (S) Specification statement is out  
of order.  Statement is ignored.
"debug_call.f", line 25.6: 1514-050 (S) Specification statement is out  
of order.  Statement is ignored.
** debug_call   === End of Compilation 1 ===
1501-511  Compilation failed for file debug_call.f.
make: *** [debug_call.o] Error 1
ocnpc84:~/myDir/MITgcm/verification/exp0/build beck$

I really have no idea what is causing these errors, I have no problems  
running later versions of the model and I expect that this version  
comes out of CVS in working order

It seems that it is something to do with the xlf compiler, has anyone 
else had similar issuses?



On Apr 5, 2006, at 9:46 PM, Ed Hill wrote:

> On Wed, 2006-04-05 at 21:04 -0400, Michael Beck wrote:
>> I am trying to run the verification exp0 in version 52k_post on a G5
>> machine and running make I come up across the error message:
>> $ make
>> /opt/ibmcmp/xlf/8.1/bin/f77 -qfixed=132 -qsuffix=f=for -O3 -c  debug_call.f
>> /opt/ibmcmp/xlf/8.1/bin/f77: 1501-218 file debug_call.f contains an
>> incorrect fi
>> make: *** [debug_call.o] Error 1
>> Any ideas? I checked out this version from CVS and have not yet  altered it
> Hi Michael,
> The email you sent above appears to contain an incomplete error message
> (that is, your copy-and-paste of the error into the email was not
> complete).  In any case, a quick google search turns up numerous  reports
> of errors such as:
> xlf: 1501-218 file a.out contains an incorrect file suffix
> http://www.unidata.ucar.edu/support/help/MailArchives/netcdfgroup- 
> list/msg00675.html
> http://www.mail-archive.com/fms-users@lists.sourceforge.net/ msg00002.html
> which appears to mean that you have a file suffix problem.  Could you
> please try omitting the "-qsuffix=f=for" and see if that helps?
> Ed
> -- 
> Edward H. Hill III, PhD
> office:  MIT Dept. of EAPS;  Rm 54-1424;  77 Massachusetts Ave.
>              Cambridge, MA 02139-4307
> emails:  eh3 at mit.edu                ed at eh3.com
> URLs:    http://web.mit.edu/eh3/    http://eh3.com/
> phone:   617-253-0098
> fax:     617-253-4464
> _______________________________________________
> MITgcm-support mailing list
> MITgcm-support at mitgcm.org
> http://mitgcm.org/mailman/listinfo/mitgcm-support

Michael Beck

Dept. of Oceanography
Florida State University

----- End forwarded message -----

This message was sent using IMP, the Internet Messaging Program.

More information about the MITgcm-support mailing list