[MITgcm-support] Re: more gchem questions

Martin Losch mlosch at awi-bremerhaven.de
Thu Sep 18 03:09:03 EDT 2003


Steph,

I agree, GCHEM_FORCING is probably the best place for it, although the 
resulting code is not very clean, again I agree. Maybe something like 
this in THE_CORRECTION_STEP:

#ifdef ALLOW_TIMEAVE
         IF (taveFreq.GT.0.) THEN
           CALL TIMEAVE_STATVARS(myTime, myIter, bi, bj, myThid)
cswdptr -- add ---
#ifdef ALLOW_PTRACERS
#ifndef PTRACERS_SEPERATE_FORCING
           CALL PTRACERS_STATVARS(myTime, myIter, bi, bj, myThid)
#endif /* PTRACERS_SEPERATE_FORCING */
#endif /* ALLOW_PTRACRES */
cswdptr -- end add ---
         ENDIF
#endif /* ALLOW_TIMEAVE */

And in GCHEM_FORCING at the end of the bibj-loop:

#ifdef PTRACERS_SEPERATE_FORCING
C     time averaging directly, here otherwise in the_correction_step
           CALL PTRACERS_STATVARS(myTime, myIter, bi, bj, myThid)
#endif /* PTRACERS_SEPERATE_FORCING */

What do you think? This should work. (I just hope that I didn't come up 
with the flag, there is a spelling error in there (o: ). I think I'll 
do it this way.

Martin

PS.
I would love to check-in my bgc-model, just to have a variety of models 
available to choose from or to compare. Also the diagnostics for all 
bgc-models should be similar and I could offer you mine and ask for 
yours. For example, yesterday I struggled to compute the carbon export 
(because with variable KAPPA it's not straightforward). But 
unfortunately my (or rather Markus Schartau's) model is written in F90, 
and I couldn't convince him to rewrite it (o:


On Wednesday, September 17, 2003, at 08:11 PM, Stephanie Dutkiewicz 
wrote:

>> Is that intentional? If so why?
>> I think PTRACERS_STATVARS should be called after the call to
>> GCHEM_FORCING, shouldn't it?
>
> No it was not intentional. I was trying to keep things neat.
> But you are right it should come after the gchem_forcing call.
> Actually maybe at the end of gchem_forcing? (It needs a
> bi,bj loop, so I'd rather put it there than in forward_step.F).
> Would you agree?
>
> steph
>




More information about the MITgcm-support mailing list